Published: 2005-09-01
Applies to:
- Content Studio PDF Server
Type: Bug
Symptoms
After installing Servicepack 1 on Windows Server 2003 running Content Studio PDF
server the service might not be able to generate PDF:s any more. Also the Content
Studio PDF Server can generate an Out of memory exception.
Cause
There is a problem in the underlying third party product Active PDF WebGrabber that
can cause the WebGrabber to stop working. Also Active PDF has changed the type library
for one of the core components so that Content Studio PDF server fails to use it.
Resolution
Upgrade Active PDF server and Active PDF WebGrabber to servicepack 7. More information
can be found on the Active PDF download site at http://www.activepdf.com/downloads/servicepacks/
After this customers must update the file CSPDFWorker.dll on the PDF server. (Normally
this file is installed in the C:\Program Files\Teknikhuset\CSPDFServer). Before
replacing the file you should stop the Content Studio PDF Server Service and restart
it afterwards. The best way of doing this is to use the Content Studio PDF Server
Manager installed with the product.
Download
CSPDFWorker.dll.